Python生成whl文件出错:python setup.py sdist bdist_wheel

Author: peter | Date: 2019/06/27| Category: 问题处理 | Tags: , , ,

今天使用python3.7命令生成whl文件出错:

> python setup.py bdist_wheel

usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] …]

or: setup.py –help [cmd1 cmd2 …]

or: setup.py –help-commands

 or: setup.py cmd –help

error: invalid command ‘bdist_wheel’

 

网上查了好久大部分的解决方案都是如下:

pip install wheel

pip install –upgrade setuptools

后来经过多次查找终于发现问题,原来setup.py文件的引用包错了,改成如下即可:

#from distutils.core import setup

from setuptools import setup

评论留言